What is RIP (Routing Information Protocol)

Administrative Distance (AD)

Before starting RIP we should about Administrative Distance (AD).
AD: Sets the priority of routing protocols. If 2 protocols are configured on a router, the router will first put the data of the low AD protocol in the routing table.
The table below contains the administrative distance values of the routing protocols. The data of the protocol with a low AD value is placed first in the routing table.

Source of RouteAD (Administrative Distance)
CONNECTED İNTERFACE0
STATİC ROUTE1
EIGRP90
IGRP100
OSPF110
RIP120
EXTERNAL EIGRP170
UNKNOWN255 (This is never used)

RIP (Routing Information Protocol)

  • Open standard protocol (cisco/non-cisco)
  • Classful routing protocol for version 1
  • Classless routing protocol for version 2
  • Updates are broadcasted via 255.255.255.255
  • Metric: Hop count
  • Load balancing up to 4 equal paths
  • Maximum hop count:15 / Max Routers:16
  • Administrative Distance: 120
  • Exchange the entire routing table every 30 seconds.
  • Applicable for small networks

      There are 2 versions of RIP, RIPv1 AND RIPv2. Everything of these 2 protocols is almost the same. Their main difference is that only RIPv1 is classful and RIPv2 is classless. The table below shows the differences between them.

RIPv1RIPv2
Distance vectorDistance Vektor
Maximum hop count 15Maximum hop count 15
ClassfulClassless
Broadcast basedMulticast based (224.0.0.9)
Doesn’t support VLSMSupport VLSM
No authenticationMD5 authentication
Don’t support discontiguous networksSupport discontiguous networks

        RIP is a distance-vector routing protocol. RIP updates the entire routing table every 30 seconds. RIP uses only the hop count to determine the best route to a remote network. By default, it has a maximum of 15 acceptable hops. So, 16 is considered inaccessible. RIP works well in small networks but is inadequate in large networks with low WAN links and networks with many routers.
RIP version1 uses only classful routing. So, all devices on the network must use the same subnet mask. Therefore, the RIP version1 does not send updates with a subnet mask. RIP version2 provides prefix routing and sends route updates and subnet masks. This is specified as classless routing.

  • Update timer (30 sec): It is the periodic routing update time that the router sends a full copy of the routing table to all its neighbors.
  • Invalid timer (180 sec): It is the time that a router must take to deem a route invalid. It achieves this result by not receiving any updates about a specific route. When this happens, the router will send updates to all its neighbors to let them know that the route is invalid.
  • Holddown timer (180 sec): Adjusts the amount of time when routing information is cut. When an update package is received stating that the route is inaccessible, the routers go into the hold-down state. This continues until an update package with better metrics is received or the hold-down timer expires.
  • Flush timer (240 sec): Sets the time between when a route becomes invalid and its removal from the routing table. Before being removed from the table, the router announces to its neighbors that the death of this router is imminent.

RIP Routing  Configuration
Configuration RIPv1:
Router (config)#Router RIP
Router (config-router)#Network <network ID>

Configuration RIPv2:
Router (config)#Router RIP
Router (config-router)#Network <network ID>
Router (config-router)#version 2

Checking the Accuracy of Your Configurations

show ip route: Displays configured routes.
show ip protocols: Shows the routing protocols configured in the router.
debug ip rip: Send routing updates to the console session as if they were being sent and received on the router. If you telnet to the router, you must use the terminal monitor command to output the debug command.

Now let’s configure the rip configuration on the example below and check its correctness with the show ip route command.

Example RIP Configuration:

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#version 2

R2(config)#router rip
R2(config-router)#network 10.0.0.0
R2(config-router)#network 11.0.0.0
R2(config-router)#network 192.168.2.0
R2(config-router)#version 2

R3(config)#router rip
R3(config-router)#network 11.0.0.0
R3(config-router)#network 192.168.3.0
R3(config-router)#version 2

      The configuration done above is for RIP only. Giving ip and activating the interface addresses is beyond this issue. For this, you can see the article How to configure cisco router at https://techsoftcenter.com/how-to-configure-the-router.

R3# show ip route
Gateway of last resort is not set

R    10.0.0.0/8 [120/1] via 11.0.0.1, 00:00:19, Serial 0/0/0
11.0.0.0/24 is subnetted, 1 subnets
C    11.0.0.0 is directly connected Serial 0/0/0
C    192.68.3.0/24 is directly connected, FastEthernet 0/0
R    192.168.1.0/24 [120/2] via 11.0.0.1, 00:00:19, Serial 0/0/0
R    192.168.2.0/24 [120/1] via 11.0.0.1, 00:00:19, Serial 0/0/0

The letter R indicates networks learned by RIP, and the letter C indicates directly connected networks. [120/1] From the numbers in parentheses, the value 120 on the left shows Administrative Distance, and the value on the right shows the number of hops. In other words, it shows how many routers it takes to reach the target network. As you can see above, 1 is shown to the right of the parenthesis because 1 router must pass through R3 to reach the 192.168.2.0 network. However, as 2 Routers must be passed to reach the 192.168.1.0 network from R3, 2 is written to the right of the parenthesis.

I hope it helped.