ORA-12502: TNS:LISTENER RECEIVED NO CONNECT_DATA FROM CLIENT

ORA-12502: TNS:LISTENER RECEIVED NO CONNECT_DATA FROM CLIENT

Error:

When clients attempt to connect to the database, they can not connect with the error “ORA-12502: TNS: listener received no CONNECT_DATA from the client”.

Now we will try to find out both the causes and how to solve this problem.

Reason:

Missing host definition in the local_listener parameter.

Solution:

The definition in the local_listener parameter should be changed as follows.

Missing Host Definition:

(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP) (HOST = node-VIP) (PORT = 1521))))

Correct Host Definition:

(DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP) (HOST = node-vip.domain.local) (PORT = 1521))))

If the database is RAC, the definition of sid = ‘XX’ should also be added.

SQL> alter system set local_listener='(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=node01-vip.domain.local)(PORT=1521))))' scope=both sid='ORCL1';