Security

Working with Snort Rules

Fadıl

Automatically Updating Snort Rules

There are multiple tools available to update Snort signatures. When using any of these tools you must be careful because you may accidentally modify or delete your customized rules. I shall discuss two methods of updating the rules.

The Simple Method

This method consists of a simple shell script. It requires that you have wget program installed on your system. The wget program is used to retrieve any file using the HTTP protocol. In essence, it is just like a web browser, but it retrieves one file from a command line argument.

HTTP Authentication Mode

Fadıl

SIP is similar to the HTTP protocol. The authentication mode. HTTP protocol (RFC 2616) provides for the Base mode and digest mode the (Digest schema). RFC 2617 devoted to the two modes of authentication requirements. RFC 1321 MD5 Standard. Digest modern password cracking is not strong, but still much better than the basic mode. MD5 has been a professor of Shandong University, to find ways to counterfeit (I understand), but is still widely used.

Networking Protocols with Nmap

Networking Protocols with Nmap

Fadıl

There are four types of protocols IP, UDP, TCP, ICMP and these are the protocols that are used by Nmap to perform scans on any target.

IP – Internet Protocol

TCP – Transmission Control Protocol

UDP – User Datagram Protocol

ICMP – Internet Control Message Protocol

What is a Protocol?

We are talking about protocols and about some heck around here but before we proceed let’s discuss what actually protocol is?

Change the MAC Address of any Windows PC

Fadıl

Here now I am on the best topic on how to change the MAC address (Media Access Control). Yeah! Your MAC address can be spoofed.

There are many ways to change the MAC address which I will show them in my later posts but now in this tutorial, I am going to use a utility named TMAC which lets you change.

TMAC stands for Technitium MAC Address Changer. Click here to download it. Once after installing if you ran that software you can find different adapters or network cards you are using and thereafter selecting the card you can enter your own customized address or you can select from the preloaded profiles.

What is a worm and what are the top 10 worms of all time?

What is a worm and what are the top 10 worms of all time?

Fadıl

Hello Everybody! This is article again on techsoftcenter to discuss worms, some creepy worms in computers. In my previous post, I have already discussed the virus, top 10 hacks, iloveyou virus, and its source code.

What is a worm?

The worm is an animal which moves very slowly and this is according to science. In computers, the worm is something which makes the computer slow by replicating itself. Maximum worms won’t do any harm but they will replicate themselves and captures free space.