Cisco

Introduction to the Border Gateway Protocol (BGP) Part-3

Fadıl

iBGP

Scaling the iBGP mesh

  • Two methods:

BGP Confederations 

BGP Route Reflectors

BGP Confederations

  • Method to subdivide a single AS into multiple, internal sub-AS’s, yet still advertise a single AS to external peers
  • Reduces iBGP mesh

BGP Confederation

  • AS10
  • AS20
  • AS30
  • AS300

BGP Route Reflectors (RR)

  • Another method to reduce iBGP mesh
  • iBGP re-advertisement restrictions are relaxed
  • Single iBGP peer advertises (reflects) routes to subordinate iBGP peers
  • Clients must not peer with RR’s outside of cluster

Route Reflectors

  • (RR)
  • AS300
  • (RR)
  • (RR)

Asymmetric Routing Paradigm

  • In the Internet, it is impossible to control end-to-end routing and paths traversed
  • Packets may not always traverse same downstream path as they do when forwarded upstream

Asymmetric Routing

Achieving stability

  • Using loopbacks
  • BGP/IGP Interaction
  • Peer groups
  • Route-flap dampening
  • BGP soft reconfiguration

Stable iBGP Peering

  • Peer with loop-back addresses
  • iBGP session is not dependent on a single interface
  • Loop-back interface does not go down

Peering to Loop-Back Address

Introduction to the Border Gateway Protocol (BGP) Part-2

Fadıl

Multi-Exit Discriminator (MED)

  • Non-transitive

  • Used to convey the relative preference of entry points

  • Influences best path selection

  • Comparable if paths are from same AS

  • IGP metric can be conveyed as MED

  • Multi-Exit Discriminator

  • AS 201

  • AS 200

  • A

  • C

  • B

  • 68.1.0/24

  • 68.1.0/24 1000

  • 68.1.0/24 2000

Applying Policy with BGP

  • Policy based on AS path, community or the network
  • Rejecting/accepting selected routes
  • Set attributes to influence path selection

Communities

  • BGP attribute
  • Used to group destinations
  • Represented as an integer
  • Each destination could be member of multiple communities
  • Community attribute carried across AS
  • Useful in applying policies
  • Community Attribute
  • RFC1997, RFC1998
  • Optional attribute
  • Range: 0 to 4,294,901,760
  • Method to group destinations into communities and apply routing decisions (accept, prefer, redistribute, etc.) using route-maps

Community attribute (cont.)

  • Format — aa:nn
  • aa’ -- ASN
  • nn’ — 1 to 4,294,901,760

BGP Communities

  • Community 10:200
  • Community 10:300
  • Community 10:200
  • Community 10:300

Load Balancing

  • BGP does not load-balance traffic; it chooses & installs a “best” route.

BGP Load Balancing Problem

  • “Since BGP picks a ‘best’ route based upon most specific prefix and shortest AS_PATH,
    it becomes non-trivial to figure out how to manually direct specific portions of internal traffic (prefixes) in a distributed fashion across multiple external gateways.”

eBGP Multihop

BGP Multipath

Difficulties in Load Balancing

Internal BGP (iBGP)

  • Same routing protocol as BGP, different application
  • iBGP should be used when AS_PATH information must remain intact between multiple eBGP peers
  • All iBGP peers must be fully meshed, logically; an iBGP peer will not advertise a route learned by one iBGP peer to another iBGP peer (readvertisement restriction to prevent looping)

PPT Slide

  • AS 1
  • AS 2
  • eBGP
  • eBGP
  • eBGP
  • iBGP
  • iBGP
  • Upstream
  • Provider B
  • AS200
  • Upstream
  • Provider A
  • AS100

Introduction to the Border Gateway Protocol (BGP) Part-1

Fadıl

BGP

  • What

  • Why

  • Who

  • When

  • Where

BGP version 4

  • RFC 1771
  • Intelligent route selection based  on most specific prefix and shortest Autonomous System (AS) path
  • Classless Inter Domain Routing (CIDR) support
  • Current Internet standard for inter-domain (AS) exterior routing

Border Gateway Protocol (BGP)

  • BGP version 4 is the current  de facto exterior routing protocol in the Internet
  • BGP- 4 is required for CIDR

Introduction

  • Used for carrying routing information between AS
  • Path vector protocol
  • Incremental
  • Runs over TCP (port 179)
  • Conveys information about AS path topology

BGP Between AS’s

What is MPLS?

Fadıl

MPLS stands for Multiprotocol Label Switching. Multiprotocol because it might be applied with any Layer 3 network protocol, although almost all of the interest is in using MPLS with IP traffic. But that doesn’t actually give us any idea what MPLS does for you (we’ll get to that momentarily).

Depending on which vendor you ask, MPLS is the solution to any problem they might conceivably have. So the question “What is MPLS” could have a lot of right answers. The presentations from this Spring’s MPLS Forum were all over the place on precisely this.

What’s A Netmask?

Fadıl

And Why Do I Need One?

When you set up a small network that interconnects to another network, the assignment of IP addresses and the “netmask” are very important. A lot of people get confused about this part, so here’s a short explanation of what’s going on.


IP Addresses
On a TCP/IP network, which is what you are building, every machine has a unique IP address, consisting of a total of 32-bits. The address is usually expressed as four decimal numbers separated by dots, where each number represents 8 bits of address. Each number therefore ranges from 0 to 255. (Note: the world is running out of IP addresses, so a new address scheme called IPng is being developed that uses six numbers instead of four. It is not yet actually in use.)