Publications

MS Windows Telephony Service Command Execution Exploit (MS05-040)

Fadıl

/ / TAPI Vulnerability-MS05-040
/ /
/ / Should work on Win2k sp0, sp1, sp2, sp3, sp4 any language
/ / If Telephony Service is not running you can start it by net start “Telephony Service”

Include “windows.h”

Include “stdio.h”

Include “tapi.h

typedef struct _UNICODE_STRING {
USHORT Length;
USHORT MaximumLength;
PWSTR Buffer;
} UNICODE_STRING;
typedef struct LpcSectionMapInfo {
DWORD Length;
DWORD SectionSize;
DWORD ServerBaseAddress;
} LPCSECTIONMAPINFO;
typedef struct LpcSectionInfo {
DWORD Length;
HANDLE SectionHandle;
DWORD Param1;
DWORD SectionSize;
DWORD clientBaseAddress;
DWORD ServerBaseAddress;
} LPCSECTIONINFO;

Working with Snort Rules

Fadıl

Automatically Updating Snort Rules

There are multiple tools available to update Snort signatures. When using any of these tools you must be careful because you may accidentally modify or delete your customized rules. I shall discuss two methods of updating the rules.

The Simple Method

This method consists of a simple shell script. It requires that you have wget program installed on your system. The wget program is used to retrieve any file using the HTTP protocol. In essence, it is just like a web browser, but it retrieves one file from a command line argument.

Setting NTP Client in Mikrotik

Fadıl

What NTP? Setting NTP client in Mikrotik – Anyone knows what the NTP (Network Time Protocol)? Surely many who do not know what the Network Time Protocol. NTP does not sound familiar to those who do not quite understand about computer networking. Okay, to learn more about what the NTP (Network Time Protocol) and its application in understanding NTP Mikrotik please refer to the following:

understanding NTP

Network Time Protocol, or more commonly referred to as NTP is a mechanism or protocol used to synchronize the clock in a computer system and network. This synchronization process performed in the data communication lines that typically using a communication protocol TCP / IP. So that the process itself can be seen as a process of regular data communication only exchange data packets only.

HTTP Authentication Mode

Fadıl

SIP is similar to the HTTP protocol. The authentication mode. HTTP protocol (RFC 2616) provides for the Base mode and digest mode the (Digest schema). RFC 2617 devoted to the two modes of authentication requirements. RFC 1321 MD5 Standard. Digest modern password cracking is not strong, but still much better than the basic mode. MD5 has been a professor of Shandong University, to find ways to counterfeit (I understand), but is still widely used.

Under Win32 dynamic-link library (DLL) Principles of Programming

Fadıl

Relatively large application consists of many modules, these modules were completed relatively independent functions, they collaborate with each other to complete the work of the entire software . Which there may be some module features more common, will still be used to construct other software . Constructed software , the source code for all modules statically compiled into the entire application EXE , it will create some problems: a drawback is to increase the size of the application , it will take up more disk space, the run will also consume a large amount of memory space, resulting in a waste of resources; Another disadvantage is that in the preparation of large EXE , modify the reconstruction must be adjusted to compile all the source code, increasing the complexity of the compilation process is not conducive to unit testing stage.