Publications
Introduction to the Border Gateway Protocol (BGP) Part-2
Multi-Exit Discriminator (MED)
Non-transitive
Used to convey the relative preference of entry points
Influences best path selection
Comparable if paths are from same AS
IGP metric can be conveyed as MED
Multi-Exit Discriminator
AS 201
AS 200
A
C
B
68.1.0/24
68.1.0/24 1000
68.1.0/24 2000
Applying Policy with BGP
- Policy based on AS path, community or the network
- Rejecting/accepting selected routes
- Set attributes to influence path selection
Communities
- BGP attribute
- Used to group destinations
- Represented as an integer
- Each destination could be member of multiple communities
- Community attribute carried across AS
- Useful in applying policies
- Community Attribute
- RFC1997, RFC1998
- Optional attribute
- Range: 0 to 4,294,901,760
- Method to group destinations into communities and apply routing decisions (accept, prefer, redistribute, etc.) using route-maps
Community attribute (cont.)
- Format — aa:nn
aa’ -- ASN- nn’ — 1 to 4,294,901,760
BGP Communities
- Community 10:200
- Community 10:300
- Community 10:200
- Community 10:300
Load Balancing
- BGP does not load-balance traffic; it chooses & installs a “best” route.
BGP Load Balancing Problem
- “Since BGP picks a ‘best’ route based upon most specific prefix and shortest AS_PATH,
it becomes non-trivial to figure out how to manually direct specific portions of internal traffic (prefixes) in a distributed fashion across multiple external gateways.”
eBGP Multihop
BGP Multipath
Difficulties in Load Balancing
Internal BGP (iBGP)
- Same routing protocol as BGP, different application
- iBGP should be used when AS_PATH information must remain intact between multiple eBGP peers
- All iBGP peers must be fully meshed, logically; an iBGP peer will not advertise a route learned by one iBGP peer to another iBGP peer (readvertisement restriction to prevent looping)
PPT Slide
- AS 1
- AS 2
- eBGP
- eBGP
- eBGP
- iBGP
- iBGP
- Upstream
- Provider B
- AS200
- Upstream
- Provider A
- AS100
Introduction to the Border Gateway Protocol (BGP) Part-1
BGP
What
Why
Who
When
Where
BGP version 4
- RFC 1771
- Intelligent route selection based on most specific prefix and shortest Autonomous System (AS) path
- Classless Inter Domain Routing (CIDR) support
- Current Internet standard for inter-domain (AS) exterior routing
Border Gateway Protocol (BGP)
- BGP version 4 is the current de facto exterior routing protocol in the Internet
- BGP- 4 is required for CIDR
Introduction
- Used for carrying routing information between AS
- Path vector protocol
- Incremental
- Runs over TCP (port 179)
- Conveys information about AS path topology
BGP Between AS’s
Mikrotik How to Config Kid Control to Manage Your Child
“Kid control” is a parental control feature to limit internet connectivity for LAN devices.
Now, wanna show you about the new feature from Mikrotik is kid control. Kid control is a feature for the parent to manage child for the day/time for those to use the internet not let see.
Copy the mac address from the ARP table and paste it to the new kid control device mac address.

What is MPLS?
MPLS stands for Multiprotocol Label Switching. Multiprotocol because it might be applied with any Layer 3 network protocol, although almost all of the interest is in using MPLS with IP traffic. But that doesn’t actually give us any idea what MPLS does for you (we’ll get to that momentarily).
Depending on which vendor you ask, MPLS is the solution to any problem they might conceivably have. So the question “What is MPLS” could have a lot of right answers. The presentations from this Spring’s MPLS Forum were all over the place on precisely this.

Professional Java Security : Symmetric Encryption Part 3
Key Storage
One of the primary difficulties in establishing good security through cryptography is key storage. In order for a key to be useful, it must be persistent. But by keeping the key around, we risk it being compromised. Let’s imagine that we want to encrypt some personal files on our computer so that no one can read them. We create a 448-bit Blowfish key and encrypt our files with it, thinking that our files will now be secure. But if someone were to get into our machine, they’d be able to read the key and decrypt the files. In order for the files to be safe, we have to protect the key that we used to encrypt those files.